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Introduction to .NET Technology



What is .NET ?

Microsoft.NET is a Framework

— Microsoft .NET is a Framework which provides a common
platform to Execute or, Run the applications developed in
various programming languages.

— Microsoft announced the .NET initiative in July 2000.

— The main intention was to bridge the gap in
interoperability between services of various

programming languages.



.NET Framework Objectives

* The .NET Framework is designed to fulfill the following
objectives:

— Provide object-oriented programming environment

— Provide environment for developing various types of
applications, such as Windows-based applications and Web-
based applications

—To ensure that code based on the .NET Framework can
integrate with any other code
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* The .NET Framework consists of:

— The Common Language Specification (CLS)

It contains guidelines, that language should follow so that they
can communicate with other .NET languages. Itis also
responsible for Type matching.

— The Framework Base Class Libraries (BCL)
A consistent, object-oriented library of prepackaged
functionality and Applications.

— The Common Language Runtime (CLR)
A language-neutral development & execution environment
that provides common runtime for application execution .



Common Language Specification

CLS performs the following functions:

» Establishes a framework that helps enable cross-language
integration, type safety, and high performance code
execution

* Provides an object-oriented model that supports the
complete implementation of many programming languages

» Defines rules that languages must follow, which helps
ensure that objects written in different languages can
interact with each other



NET Framework Base Class Library

The Class Library is a comprehensive, object-oriented collection
of reusable types

These class library can be used to develop applications that
include:

— Traditional command-line applications

— Graphical user interface (GUI) applications

— Applications based on the latest innovations provided by ASP.NET
 Web Forms
* XML Web services

Unified Classes
Web Classes (ASP.NET)

Controls, Caching, Security, Session, Configuration etc

Data (ADO.NET) || Windows Forms
ADO, SQL,Types etc Design, Cmpnt Model etc




Common Language Runtime (CLR)

* CLR ensures:

— A common runtime environment for all .NET languages
— Uses Common Type System (strict-type & code-verification)
— Memory allocation and garbage collection

— Intermediate Language (IL) to native code compiler. Which
Compiles MSIL code into native executable code

— Security and interoperability of the code with other
languages

* Over 36 languages supported today

— C#, VB, Jscript, Visual C++ from Microsoft

— Perl, Python, Smalltalk, Cobol, Haskell, Mercury, Eiffel, Oberon, Oz, Pascal, APL,
CAML, Scheme, etc.
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Visual Studio 2008 IDE

Microsoft has introduced Visual Studio.NET,
which is a tool (also called Integrated Development

Environment) for developing .NET applications by
using programming languages such as VB, C#,

VC++ and VJ#. etc.



C# (C Sharp)

Microsoft C# (pronounced C Sharp) developed by Microsoft
Corporation, USA

New programming language that runs on the .NET Framework

C# is simple, modern, type safe, and object oriented

CH# code is compiled as managed code

Combines the best features of Visual Basic, C++ and Java



CH# Features

Simple

Modern
Object-Oriented
Type-safe
Versionable
Compatible

Secure



Introduction to Web Based
Applications



Introducing Web Applications

Web Page Static web page

« This type of web page consists of
HTML code typed directly into text

or a web page editor
* ltissaved asan .htmor .html
file

« The content (text, images, hyperlinks, and so on) and
appearance of a static web page is always the same.

 These web pages do not utilize any database or any
other technology that dynamically builds up pages or
content at runtime based on their visitors input.
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How Are Static Web Pages Served ?

WEB SERVER

Author I
writes
HTML

Client requests
the web page

3. Web Server locates
.html file

4, HTML stream( from the
.html page) returned to

the browser

5. Browser processes
HTML and displays

page

CLIENT
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Dynamic web page

Dynamic Web sites provide its visitors to modify the content of
the web page based on their input.

They utilize databases and other mechanisms that enable to

— identify their visitors
— present them with customized greeting messages
— restructure the content according to user input etc..

Examples: -
: : Google ==

— Online shopping stores, e s

— search engines A W

— email T s

— chat, community portals etc. o i



Dynamic web page

* Dynamic Web sites make use of “server-side
technology”.

e Server-side technologies add an extra layer to the
static web page that enables the Web Server to

generate HTML on the fly.
 The web server will first
— interpret the server-side code present in web
pages,
— generate the appropriate HTML and then
— send the response to the web browser.



How Are Dynamic Web Pages Served?

3. Web Server collects the contents
{‘ (code + HTML) of the web page
WEB SERVER and parses the contents to

produce HTML.

2. The Web Server
searches for the

requested page 4. The HTML stream is

sent back to the
requesting browser

5. Browser processes
HTML and displays

page

1. The Web browser
sends a request

CLIENT
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Introduction to ASP.NET




Introduction to ASP.NET

® ASP.NET is part of the Microsoft .NET framework

® ASP.NET is an effective and flexible technology for
creating interactive and dynamic web
pages.

® |t is a convergence of two major Microsoft technologies:

— Active Server Pages (ASP)

* Active Server Pages is Microsoft’s server side scripting
technology for building dynamic web pages.

— .NET Framework

 The .NET Framework is a suite of technologies designed by
Microsoft where program development takes place.



Introduction to ASP.NET

® |t is built on .NET Common Language Runtime
® ASP.NET :

® Provides better user authentication
® Has better language support.
® Has a large set of new controls (web controls)
® Uses compiled code, which increases the performance of the
applications
® |t is programmable using any of the .NET languages
(VB.NET, C#, VI# etc).

® The ASP.NET pages are saved with the . aspx
extension.



Working of an ASP.NET Application

To execute an ASP.NET file, the

2.

3.

following steps are followed:

A web browser sends a
request for an ASP.NET file to
the web server by using a
URL.

The web server receives the
request and retrieves the
appropriate ASP.NET file from
the disk or memory.

The web server forwards the
file to the ASP.NET script
engine for processing.

» ASP.NET

Script
Engine

CLIENT
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Working of an ASP.NET Application

4. The ASP.NET script engine reads

the file from top to bottom and
executes it.

5. The processed ASP.NET file is
generated as an HTML
document and the ASP.NET
script engine sends the HTML
page to the Web server.

6. The Web server then sends the
HTML code to the client which
interprets the output and
displays it.

» ASP.NET

Script
Engine

CLIENT
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Advantages of ASP.NET

Easy Programming Model
Flexible Language Options
Compiled Execution

Rich Output Caching
Web-Farm Session State
Enhanced Reliability
Master Pages

Themes

Improved Security

Web Services

Improved Performance and Scalability



Visual Studio 2008 IDE
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Creating a New Web Application

To start a new Web Application in VS 2008, Click the Create Web Site

button on the Start page or Select File > New > Web Site

New Web Site

The New Web Site allows
you to choose:

« Templates

- Language for creating an
application

- Location where the application
will be created

Templates:

__ Visual Studio installed templates

2\2 2 ¢ #

ASP.MET Web JASP.MET Web PersonalWeb  Empty Web  ASP.NET
Site Service  Site Starter Kit Site CrystalRe...

My Templates

Search Online

Templates. ..
| & blank ASP.ET Wb site
Location; 7Fi|e System 4 7C:\TestWebAppIicationr|

EE

-Browse. 41

” Cancel ]
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Creating a New Application
(Continued)

= After you create a new Web Application, Default.aspx page is added to this
Website. To Rename this page, Select the page from the Website node in the
Solution Explorer > Right Click > Rename,

Solution xplor - A TestWebapplication’,

Add New Item - C:\Documents and Settings\hussain. patei\My Documents\Wisual Studio 2005\WebsS... @@

= Files can be added to the Project, fewes: BE
. . Visual Studio installed templates ~
using Solution Explorer: = i
. . . . ] HTML Page QWeb Service <#] Class
= Right cllc_k on the project node, in R ¢ it B i
the Solution Explorer, and select | Siuils. Heere 5
the Optlon Add NeW Item_ i;]?;brf:::;b o \ggsbcﬂ';:)\tv:l:mer Control %;:thetConfgwationHe
L XRAT f - dz in File ] Browser Fil
= The Add New Item window will s ‘
popup. Yy : .
= Select the type of file (item) to be |- Defaur2 o
- Language! | Visual C# v V| Place code in separate file
added and click on Add. = S
[ Add ” Cancel ]

X Remove

Property Pages

28



Solution Explorer

= Presents a tree view structure of files
present in the project.

Sohution Explorer - Solution 'Website{' (1 project)

IBERED

) _ . "] Solution "Websitet' {1 project)
— By default a New Website will contain: 2 i C\..\Website1\
Rl Arp Dats
* An App_Data folder = [ Defauit asp
"

* A Default.aspx page (including
Default.aspx.cs)

To view Solution Explorer:

= Select View > Solution Explorer
OR

= Press buttons Ctrl+W,S
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Solution Explorer (Continued)

= The Toolbar at the top of Solution Explorer enables various tasks.

Code
Refresh Copy Website

Solution| Explorer -

2] |&3 JT

Properties

Designe
Nest =igner ASP.NET

Related Configuration
Files



Toolbox

To add controls in the Design Window use
Toolbox.

There are various tool tabs available in the
Toolbox.

— The controls in the IDE are presented in a
hierarchical manner (e.g., Standard Tab, Data Tab,
Validation, Navigation, WebParts etc.).

— Depending on the type of project (application) the
toolbox tabs will vary.
To view the tool box:
— Select menu View > Toolbox
OR
— Press buttons Ctrl+Alt+X or Ctrl+W, X
You can also view the controls as icons by right-

clicking on the toolbox you want to change and
deselecting the List View.

Toolbox
|+ Standard
i= Data
R Pointer
A Gridview
] Datalist
J—J DetailsView

;J FormView

““ Repeater

d SqiDataSource
LJp AccessDataSource
3 ObjectDataSource
'.‘ii) ¥miDataSource
L;h SiteMapDataSource
i Reportiewer

i+ ¥alidation

{+. Navigation

i+ Login

i+ WebParts

+ HTML

(+ Crystal Reports
= General

There are no usable controls in this group. Drag
an item onto this text to add it to the toolbox.
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Properties Window

To view or change the properties and events of a selected control during
design use the Properties Window

To configure a control:
— Click once to select it

— Press F4 or Select menu View > Properties
window

— Modify the appropriate properties in the window

There are various options provided for viewing
the properties of the selected control, such as:
— Categorized view
— Alphabetical view
— Properties view (default)
— Events View B fayou
— Property pages S T

{ID) Buttonl

Properties

True
True
o

Trues
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Adding an Event

Events can be added to ;.:,;u e —— |
the code in one of three
ways. gu[z -
1. Double clicking a control in | SXismsns

design view itpdd

2. Typing the code manually PreRender

3. Selecting the Events Icon
and double clicking the
required event from the
Properties Window

Click
Fires when the button is clicked.
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Project Settings

Project Settings can be adjusted using
various options in the Project
Properties menu or by using the
Solution Explorer window.

— These settings change based on the
type of application developed.

Setting Startup Page:
— Right Click on the form you want set as

the startup page in the Solution Explorer.

— Select option Set As Start Page.

Startup Project (In case of multiple
projects):
— Right Click on Project to set as startup
project in the Solution Explorer.

— Select Option Set As StartUp Project.

(2 2] §a 6’4, 50

3 J Solutlon CustomerManagement (2 prcqects)
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Publish \Web Site

add New Item...

Add Existing Item...
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Add Reference...
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View Class Diagram
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Start Options...

Set as StartUp Project

View in Browser
Browse With...
Refresh Folder
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Cut

Remove

Property Pages




Resources

* Visual Studio 2008 Website
http://msdn.microsoft.com/vstudio/
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http://msdn.microsoft.com/vstudio/

Questions and Comments




